All systems operational

DDoS attack

Resolved
Degraded performance
Started about 1 year ago Lasted about 5 hours

Affected

Website & API
Background queues
Media storage
Streaming API
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    We implemented a fix and we expect the queues to catch up soon.

  • Identified
    Update

    We're experiencing additional issues with background queues. Home feeds, notifications, and other things that involve asynchronous processing may be severely delayed. We're working on mitigating this issue.

  • Identified
    Identified

    We are under a massive DDoS attack. We are working together with Fastly to mitigate it.

  • Investigating
    Investigating

    mastodon.social is currently unavailable.

    We are currently investigating this incident.