mastodon.social - Server autoscaling/capacity issues – Incident details

All systems operational

Server autoscaling/capacity issues

Resolved
Degraded performance
Started 7 days agoLasted about 19 hours

Affected

Website & API

Degraded performance from 4:17 PM to 10:48 AM

Background queues

Degraded performance from 4:17 PM to 10:48 AM

Streaming API

Degraded performance from 4:17 PM to 10:48 AM

Updates
  • Resolved
    Resolved

    Capacity issues have been resolved, and the autoscaler has been adjusted.

  • Identified
    Identified

    There was an issue with our cluster autoscaler where it seems to have scaled down the number of nodes we have for our cluster, resulting in strained resources. We are trying to scale back up, but Hetzner is having availability issues in the region we are deployed in. We are working to resolve the issue as quickly as possible.