mastodon.social - DDoS attack in progress – Incident details

All systems operational

DDoS attack in progress

Resolved
Major outage
Started 20 days agoLasted about 20 hours

Affected

Website & API

Major outage from 9:48 AM to 10:05 AM, Degraded performance from 10:05 AM to 10:40 AM, Operational from 10:40 AM to 5:54 AM

Background queues

Operational from 9:48 AM to 5:54 AM

Media storage

Operational from 9:48 AM to 5:54 AM

Streaming API

Major outage from 9:48 AM to 10:05 AM, Degraded performance from 10:05 AM to 10:40 AM, Operational from 10:40 AM to 5:54 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Update
    Update

    The attack seems to have stopped. We are continuing to monitor the situation.

  • Monitoring
    Monitoring

    We have enabled DDoS protection methods, and services is mostly restored. We still continue to monitor the situation.

  • Identified
    Identified

    We are (again) targeted by a DDoS attack and mastodon.social may not be available while we mitigate it.