Scheduled for January 21, 2025 at 9:00 AM – 11:44 AM
Affects
Website & API
Under maintenance from 9:00 AM to 11:44 AM
Background queues
Under maintenance from 9:00 AM to 11:44 AM
Media storage
Under maintenance from 9:00 AM to 11:44 AM
Streaming API
Under maintenance from 9:00 AM to 11:44 AM
Completed
January 21, 2025 at 11:44 AMCompleted
January 21, 2025 at 11:44 AMDatabase is successfully upgraded, all configuration errors have been cleaned up. Thank you to everyone for your patience.
Update
January 21, 2025 at 11:00 AMIn progress
January 21, 2025 at 11:00 AMThe upgrade was successful and mastodon.social is now running on the newer database servers.
There is a small delay in processing due to the backlog of request accumulated during our downtime, but everything should be back to real-time soon.
We are closely monitoring the servers and will update this status once everything is back to normal.
Update
January 21, 2025 at 9:57 AMIn progress
January 21, 2025 at 9:57 AMWe encountered a configuration issue while performing the update. We are working on a fix and the service should be back online soon.
Update
January 21, 2025 at 9:31 AMIn progress
January 21, 2025 at 9:31 AMMaintenance is now in progress.
Update
January 21, 2025 at 9:00 AMIn progress
January 21, 2025 at 9:00 AMMaintenance is now in progress
In progress
January 21, 2025 at 9:00 AMIn progress
January 21, 2025 at 9:00 AMWe will be upgrading the database systems to new hardware, as well as a new major version of PostgreSQL. The upgrade should be very quick, but some small downtime will still occur for around a minute.